fglrxinfo: error while loading shared libraries: libGL.so.1

Look around the web for a simple solution to this fglrx error. Find anything?

Try this only after verifying that you do in fact have the identified files in the stated locations.
sudo unlink /usr/lib/libGL.so.1
sudo unlink /usr/lib32/libGL.so.1
sudo rm /usr/lib/libGL.so.1.2
sudo synaptic

From there just browse to fglrx and choose the "reinstall" option. Test with glxgears.