Firefox Flash plugin: Jumpy video and no sound

Well, I took the Linux plunge today, with the installation of Ubuntu onto my old PC. I'm really pleased with it so far. However, I opted to use the Flash plugin for Firefox. The video is very jumpy and there is no sound. I know that sound is working in the general sense, since I can hear the dings when I send and receive instant messages. Can someone shed some light on this -- or barring that, tell me how to uninstall Flash?  Regards,HFZ

Hey,First of all, if you

Hey,First of all, if you could tell us which version of ubuntu ur using. Secondly, i had that problem before. I fixed my problem by installing non-free version of flash player 9. This is how you do it. Ahh.. few tips before you proceed.To install/uninstall packages (programs). You go System/Administration/Synaptics Package Manager. You can go under installed and look for flash or something like mozilla-flash etc. Uninstall it. Then go to not installed and look for flashplugin-nonfree click it for installation and press apply. (I would make sure u have mozilla closed when u do those steps).If you can't find flashplugin-nonfree on the list. It is possible that multiverse is not enabled in your apt.source. Note: Make sure you make copy of source.list in case you make mistake. <code>sudo cp /etc/apt/source.list /etc/apt/source.list.bak</code>If so then start Terminal and type in <code>sudo pico /etc/apt/source.list</code> You will be asked for your password, type it in, and it will start text editor. Look for lines which finish with multiverse and make sure they are not commented. Note: Commented means that it has # (hash) on front of it. When u done. Click CTRL + X and the text editor will ask you if you are willing to leave, click yes and then save it. Then you have to update your list. So you have to type in <code>sudo apt-get update</code>. If you have any errors then you have obviously done something wrong with source.list. I hope it helps, what happend in my case is that i had some old mozilla-flashplugin installed and it was playing up with my non-free one.

Hi

Are you using the 32-bit or 64 bit version of Ubuntu?Is it Ubuntu 7.04, 7.10 or 8.04?

The 64-bit version has known issues with Flash and the Firefox Flash plugin:

Ubuntu 8.04 uses Pulseaudio for sound, which has some issues with Flash

You need to install libflashsupport to fix this:
In a terminal type
sudo apt-get install libflashsupport

or use synaptic package manager to install libflashsupport.

For the 64-bit version of Ubuntu, get this file

http://nuklear.org/packages/libflashsupport_svn20080217.deb

and double click to install

For more info check these links

https://wiki.ubuntu.com/PulseAudio

http://www.psychocats.net/ubuntu/flash

Thanks

I just upgraded to 8.04 and I'm still working out the bugs, This was one of them, without the jumpy video.  libflashsupport worked great.  Thanks again