Flash Player Version 9 Beta

Installed FlashPlayer 9 beta today and it works okay but you probably want to retain existing flash player 7. (backup instructions below)

  • First, I downloaded the beta from http://labs.adobe.com/downloads/flashplayer9.html to my desktop.
  • Click on the downloaded file and extract to desktop
  • next, I used the find files gui to locate my existing libflashplayer.so location. It should be in a "plugins" folder.
  • next I backed up my existing file sudo cp /usr/local/firefox32/plugins/libflashplayer.so /usr/local/firefox32/plugins/libflashplayer.so.bak
  • then I copied the new file from desktop to plugins folder sudo cp /home/user/Desktop/flash-player-plugin-9.0.21.55/libflashplayer.so /usr/local/firefox32/plugins/libflashplayer.so(note you must insert your user name where I put user in italics.)
  • Finally, I tested the player by navigating to http://www.adobe.com/products/flash/about/ and my browser crashed. Don't worry, I simply restarted, navigated to the test page again and it worked fine. No more "You must have flash player 9 installed to view this content" messages. WooHoo!

Moving firefox window while flash is running causes error. Opening another window above flash content causes error.

Comments

Comment from digg forum

I found this comment posted in response to someone else's guide to install flash player 9: "you guys are idiots, did you know that adobe packs a readme.txt? copy to ~/.mozilla/plugins or /usr/lib/firefox/plugins/ there should be no "HOWTO". Its one fucking file and you put in one fucking place. End of story." This comment is one reason I love ubuntux, I have never seen anyone call anyone else an idiot here and please don't start. The author of that comment failed to back up existing libflashplayer.so major error as new libflashplayer.so is a beta release not suitable for production use.