unable to update my software

I am using KPackageKit to try and update all my software, my problem is I get the following error:

Dependency Resolution Failed.

A package dependency could not be found.
More information is available in the detailed report.

Details: The following packages block the installation: ppp libasound2 libglib2.0-0 isc-dhcp-client nautilus

I believe the problem started a month or so ago when I was updating software and my laptop died in the middle of an update.

I am using Ubuntu 10.04 LTS - the Lucid Lynx

Any help would be appreciated,
Thanks.