NEWBIE - Trouble installing updates... HELP!

Hi everyone!

I am new to Ubuntu and am having trouble!

I recently installed Ubuntu 8.04 and then attempted to update. There were something like 275 updates available!

So after the updater finishes, it says:
"E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report."

So I go into my terminal, type 'sudo dpkg --configure -a' and it gives me this:

foo2@foo2-desktop:~$ sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of openoffice.org-gnome:
openoffice.org-gnome depends on openoffice.org-core (= 1:2.4.1-1ubuntu2.1); however:
Version of openoffice.org-core on system is 1:2.4.1-1ubuntu2.
dpkg: error processing openoffice.org-gnome (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openoffice.org-impress:
openoffice.org-impress depends on openoffice.org-core (= 1:2.4.1-1ubuntu2.1); however:
Version of openoffice.org-core on system is 1:2.4.1-1ubuntu2.
dpkg: error processing openoffice.org-impress (--configure):
dependency problems - leaving unconfigured
Setting up xterm (229-1ubuntu1.1) ...
Can't locate Pod/Usage.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/sbin/install-docs line 18.
Global symbol "$opt_rootdir" requires explicit package name at /usr/sbin/install-docs line 136.
Execution of /usr/sbin/install-docs aborted due to compilation errors.
dpkg: error processing xterm (--configure):
subprocess post-installation script returned error exit status 9
Setting up libpango1.0-common (1.20.5-0ubuntu1) ...
Can't locate File/Copy.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/bin/defoma-app line 7.
BEGIN failed--compilation aborted at /usr/bin/defoma-app line 7.
Failed to clean up for defoma: 512 at /usr/sbin/update-pangox-aliases line 48.
dpkg: error processing libpango1.0-common (--configure):
subprocess post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of libpango1.0-0:
libpango1.0-0 depends on libpango1.0-common (>= 1.20.5-0ubuntu1); however:
Package libpango1.0-common is not configured yet.
dpkg: error processing libpango1.0-0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openoffice.org-draw:
openoffice.org-draw depends on openoffice.org-core (= 1:2.4.1-1ubuntu2.1); however:
Version of openoffice.org-core on system is 1:2.4.1-1ubuntu2.
dpkg: error processing openoffice.org-draw (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gtk2-engines-pixbuf:
gtk2-engines-pixbuf depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing gtk2-engines-pixbuf (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of evince:
evince depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing evince (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openoffice.org-gtk:
openoffice.org-gtk depends on libpango1.0-0 (>= 1.20.1); however:
Package libpango1.0-0 is not configured yet.
openoffice.org-gtk depends on openoffice.org-core (= 1:2.4.1-1ubuntu2.1); however:
Version of openoffice.org-core on system is 1:2.4.1-1ubuntu2.
dpkg: error processing openoffice.org-gtk (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libedataserverui1.2-8:
libedataserverui1.2-8 depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing libedataserverui1.2-8 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of update-notifier:
update-notifier depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing update-notifier (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpoppler-glib2:
libpoppler-glib2 depends on libpango1.0-0 (>= 1.20.1); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing libpoppler-glib2 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of deskbar-applet:
deskbar-applet depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing deskbar-applet (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of yelp:
yelp depends on libpango1.0-0 (>= 1.20.1); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing yelp (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of evolution-exchange:
evolution-exchange depends on libedataserverui1.2-8 (>= 2.22.3); however:
Package libedataserverui1.2-8 is not configured yet.
evolution-exchange depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing evolution-exchange (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of compiz-fusion-plugins-main:
compiz-fusion-plugins-main depends on libpango1.0-0 (>= 1.20.1); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing compiz-fusion-plugins-main (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgtksourceview2.0-0:
libgtksourceview2.0-0 depends on libpango1.0-0 (>= 1.20.1); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing libgtksourceview2.0-0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nautilus:
nautilus depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing nautilus (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgtkhtml3.14-19:
libgtkhtml3.14-19 depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing libgtkhtml3.14-19 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of evolution-plugins:
evolution-plugins depends on libedataserverui1.2-8 (>= 2.22.2); however:
Package libedataserverui1.2-8 is not configured yet.
evolution-plugins depends on libgtkhtml3.14-19 (>= 3.18.2); however:
Package libgtkhtml3.14-19 is not configured yet.
evolution-plugins depends on libpango1.0-0 (>= 1.20.1); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing evolution-plugins (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-restricted-modules-generic:
linux-restricted-modules-generic depends on linux-restricted-modules-2.6.24-23-generic; however:
Package linux-restricted-modules-2.6.24-23-generic is not installed.
dpkg: error processing linux-restricted-modules-generic (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pidgin:
pidgin depends on libpango1.0-0 (>= 1.20.1); however:
Package libpango1.0-0 is not configured yet.
pidgin depends on libpurple0 (>= 1:2.4.1-1ubuntu2.2); however:
Version of libpurple0 on system is 1:2.4.1-1ubuntu2.
dpkg: error processing pidgin (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gksu:
gksu depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing gksu (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of evolution:
evolution depends on libedataserverui1.2-8 (>= 2.22.2); however:
Package libedataserverui1.2-8 is not configured yet.
evolution depends on libgtkhtml3.14-19 (>= 3.18.2); however:
Package libgtkhtml3.14-19 is not configured yet.
evolution depends on libpango1.0-0 (>= 1.20.1); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing evolution (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libwnck22:
libwnck22 depends on libpango1.0-0 (>= 1.20.1); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing libwnck22 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
linux-generic depends on linux-restricted-modules-generic (= 2.6.24.23.25); however:
Package linux-restricted-modules-generic is not configured yet.
dpkg: error processing linux-generic (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of firefox-3.0:
firefox-3.0 depends on libpango1.0-0 (>= 1.20.1); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing firefox-3.0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of update-manager:
update-manager depends on gksu; however:
Package gksu is not configured yet.
dpkg: error processing update-manager (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-uno:
python-uno depends on openoffice.org-core (= 1:2.4.1-1ubuntu2.1); however:
Version of openoffice.org-core on system is 1:2.4.1-1ubuntu2.
dpkg: error processing python-uno (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nautilus-sendto:
nautilus-sendto depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
nautilus-sendto depends on nautilus-extensions-2.0; however:
Package nautilus-extensions-2.0 is not installed.
Package nautilus which provides nautilus-extensions-2.0 is not configured yet.
dpkg: error processing nautilus-sendto (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gtk2-engines-murrine:
gtk2-engines-murrine depends on libpango1.0-0 (>= 1.20.1); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing gtk2-engines-murrine (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gdm:
gdm depends on gksu (>= 1.0.7); however:
Package gksu is not configured yet.
gdm depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing gdm (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xulrunner-1.9:
xulrunner-1.9 depends on libpango1.0-0 (>= 1.20.1); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing xulrunner-1.9 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-system-monitor:
gnome-system-monitor depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
gnome-system-monitor depends on libwnck22 (>= 2.19.5); however:
Package libwnck22 is not configured yet.
dpkg: error processing gnome-system-monitor (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nautilus-share:
nautilus-share depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
nautilus-share depends on nautilus (>= 2.10); however:
Package nautilus is not configured yet.
dpkg: error processing nautilus-share (--configure):
dependency problems - leaving unconfigured

dpkg: dependency problems prevent configuration of libgweather1:
libgweather1 depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing libgweather1 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libexchange-storage1.2-3:
libexchange-storage1.2-3 depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing libexchange-storage1.2-3 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-panel:
gnome-panel depends on libedataserverui1.2-8 (>= 2.22.3); however:
Package libedataserverui1.2-8 is not configured yet.
gnome-panel depends on libgweather1; however:
Package libgweather1 is not configured yet.
gnome-panel depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
gnome-panel depends on libwnck22 (>= 2.19.5); however:
Package libwnck22 is not configured yet.
dpkg: error processing gnome-panel (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gtk2-engines-ubuntulooks:
gtk2-engines-ubuntulooks depends on libpango1.0-0 (>= 1.20.1); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing gtk2-engines-ubuntulooks (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgtk2.0-0:
libgtk2.0-0 depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing libgtk2.0-0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpanel-applet2-0:
libpanel-applet2-0 depends on libgtk2.0-0 (>= 2.12.0); however:
Package libgtk2.0-0 is not configured yet.
libpanel-applet2-0 depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing libpanel-applet2-0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of firefox-3.0-gnome-support:
firefox-3.0-gnome-support depends on firefox-3.0 (= 3.0.5+nobinonly-0ubuntu0.8.04.1); however:
Package firefox-3.0 is not configured yet.
dpkg: error processing firefox-3.0-gnome-support (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of vinagre:
vinagre depends on libgtk2.0-0 (>= 2.12.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing vinagre (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libavahi-ui0:
libavahi-ui0 depends on libgtk2.0-0 (>= 2.12.0); however:
Package libgtk2.0-0 is not configured yet.
libavahi-ui0 depends on libpango1.0-0 (>= 1.20.1); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing libavahi-ui0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-gtkhtml2:
python-gtkhtml2 depends on libgtk2.0-0 (>= 2.12.0); however:
Package libgtk2.0-0 is not configured yet.
python-gtkhtml2 depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing python-gtkhtml2 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgnome-desktop-2:
libgnome-desktop-2 depends on libgtk2.0-0 (>= 2.12.0); however:
Package libgtk2.0-0 is not configured yet.
dpkg: error processing libgnome-desktop-2 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gtkhtml3.14:
gtkhtml3.14 depends on libgtk2.0-0 (>= 2.12.0); however:
Package libgtk2.0-0 is not configured yet.
gtkhtml3.14 depends on libgtkhtml3.14-19 (>= 3.18.3); however:
Package libgtkhtml3.14-19 is not configured yet.
gtkhtml3.14 depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing gtkhtml3.14 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-games:
gnome-games depends on libgtk2.0-0 (>= 2.12.0); however:
Package libgtk2.0-0 is not configured yet.
gnome-games depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing gnome-games (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gtk2-engines:
gtk2-engines depends on gtk2.0-binver-2.10.0; however:
Package gtk2.0-binver-2.10.0 is not installed.
Package libgtk2.0-0 which provides gtk2.0-binver-2.10.0 is not configured yet.
gtk2-engines depends on libgtk2.0-0 (>= 2.12.0); however:
Package libgtk2.0-0 is not configured yet.
gtk2-engines depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing gtk2-engines (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgksu2-0:
libgksu2-0 depends on libgtk2.0-0 (>= 2.12.0); however:
Package libgtk2.0-0 is not configured yet.
libgksu2-0 depends on libpango1.0-0 (>= 1.20.5); however:
Package libpango1.0-0 is not configured yet.
dpkg: error processing libgksu2-0 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of alacarte:
alacarte depends on gnome-panel; however:
Package gnome-panel is not configured yet.
dpkg: error processing alacarte (--configure):
dependency problems - leaving unconfigured
dpkg: too many errors, stopping
dpkg: ../../src/packages.c:252: process_queue: Assertion `!queuelen' failed.
Aborted
foo2@foo2-desktop:~$

I assume this stopped because there are many many thing not working - something about 'dependencies?'

I assume this is somewhat easy to fix, as perhaps I am missing a link up/program/command of some sort!

Anyway, your help would be much appreciated!

Thanks in advance!

ubuntu 8.04.2

wow thats a lot of errors. you might want to try downloading ubuntu 8.04.2 as it has all the updates built in.

Have you tried rebooting and

Have you tried rebooting and then trying to re-update? Whenever I have updating issues this usually resolves them. Reboot, then re-upgrade.

Errors - anyone have any ideas?

I had posted previously that I was having a lot of errors with Ubuntu...

I have re-installed 8.04.2 - and things were OK till I tried to install updates.

I am getting the following errors:

E: /var/cache/apt/archives/linux-image-2.6.27-11-generic_2.6.27-11.27_i386.deb: corrupted filesystem tarfile - corrupted package archive
E: /var/cache/apt/archives/openoffice.org-calc_1%3a2.4.1-11ubuntu2.1_i386.deb: short read in buffer_copy (backend dpkg-deb during `./usr/lib/openoffice/program/libsc680li.so')
E: /var/cache/apt/archives/openoffice.org-writer_1%3a2.4.1-11ubuntu2.1_i386.deb: short read in buffer_copy (backend dpkg-deb during `./usr/lib/openoffice/program/libwriterfilter680li.so')
E: /var/cache/apt/archives/openoffice.org-core_1%3a2.4.1-11ubuntu2.1_i386.deb: conflicting packages - not installing openoffice.org-core
E: /var/cache/apt/archives/libc6-i686_2.8~20080505-0ubuntu8_i386.deb: corrupted filesystem tarfile - corrupted package archive

Any ideas how to fix this? Please keep in mind I am new - perhaps this is something I have done?

I tried some other things - please see below

I tried "sudo apt-get upgrade" - got the following (I had synaptic open - you can see a few lines - I closed it and continued)

hot5@hot5-desktop:~$ sudo apt-get upgrade
[sudo] password for hot5:
Sorry, try again.
[sudo] password for hot5:
E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
hot5@hot5-desktop:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
libc6-i686: PreDepends: libc6 (= 2.8~20080505-0ubuntu7) but 2.8~20080505-0ubuntu8 is installed
linux-restricted-modules-2.6.27-11-generic: Depends: linux-image-2.6.27-11-generic but it is not installed
openoffice.org-calc: Depends: openoffice.org-base-core (= 1:2.4.1-11ubuntu2) but 1:2.4.1-11ubuntu2.1 is installed
openoffice.org-draw: Depends: openoffice.org-core (= 1:2.4.1-11ubuntu2.1) but 1:2.4.1-11ubuntu2 is installed
openoffice.org-gnome: Depends: openoffice.org-core (= 1:2.4.1-11ubuntu2.1) but 1:2.4.1-11ubuntu2 is installed
openoffice.org-gtk: Depends: openoffice.org-core (= 1:2.4.1-11ubuntu2.1) but 1:2.4.1-11ubuntu2 is installed
openoffice.org-impress: Depends: openoffice.org-core (= 1:2.4.1-11ubuntu2.1) but 1:2.4.1-11ubuntu2 is installed
openoffice.org-math: Depends: openoffice.org-core (= 1:2.4.1-11ubuntu2.1) but 1:2.4.1-11ubuntu2 is installed
openoffice.org-writer: Depends: openoffice.org-base-core (= 1:2.4.1-11ubuntu2) but 1:2.4.1-11ubuntu2.1 is installed
python-uno: Depends: openoffice.org-core (= 1:2.4.1-11ubuntu2.1) but 1:2.4.1-11ubuntu2 is installed
E: Unmet dependencies. Try using -f.
hot5@hot5-desktop:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
libc6-i686 linux-image-2.6.27-11-generic openoffice.org-calc openoffice.org-core
openoffice.org-writer
Suggested packages:
fdutils linux-doc-2.6.27 linux-source-2.6.27 openoffice.org-gcj openoffice.org-base
openoffice.org-filter-binfilter default-jre java-gcj-compat openjdk-6-jre sun-java5-jre
sun-java6-jre java5-runtime openoffice.org-java-common openoffice.org-writer2latex
The following NEW packages will be installed:
linux-image-2.6.27-11-generic
The following packages will be upgraded:
libc6-i686 openoffice.org-calc openoffice.org-core openoffice.org-writer
4 upgraded, 1 newly installed, 0 to remove and 186 not upgraded.
8 not fully installed or removed.
Need to get 0B/60.1MB of archives.
After this operation, 94.4MB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 99874 files and directories currently installed.)
Unpacking linux-image-2.6.27-11-generic (from .../linux-image-2.6.27-11-generic_2.6.27-11.27_i386.deb) ...
Done.
dpkg: error processing /var/cache/apt/archives/linux-image-2.6.27-11-generic_2.6.27-11.27_i386.deb (--unpack):
corrupted filesystem tarfile - corrupted package archive
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Running postrm hook script /sbin/update-grub.
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found kernel: /boot/vmlinuz-2.6.27-7-generic
Found kernel: /boot/memtest86+.bin
Updating /boot/grub/menu.lst ... done

Preparing to replace openoffice.org-calc 1:2.4.1-11ubuntu2 (using .../openoffice.org-calc_1%3a2.4.1-11ubuntu2.1_i386.deb) ...
Unpacking replacement openoffice.org-calc ...
lzma: Decoder error
dpkg-deb: subprocess returned error exit status 1
dpkg: error processing /var/cache/apt/archives/openoffice.org-calc_1%3a2.4.1-11ubuntu2.1_i386.deb (--unpack):
short read in buffer_copy (backend dpkg-deb during `./usr/lib/openoffice/program/libsc680li.so')
Preparing to replace openoffice.org-writer 1:2.4.1-11ubuntu2 (using .../openoffice.org-writer_1%3a2.4.1-11ubuntu2.1_i386.deb) ...
Unpacking replacement openoffice.org-writer ...
lzma: Decoder error
dpkg-deb: subprocess returned error exit status 1
dpkg: error processing /var/cache/apt/archives/openoffice.org-writer_1%3a2.4.1-11ubuntu2.1_i386.deb (--unpack):
short read in buffer_copy (backend dpkg-deb during `./usr/lib/openoffice/program/libwriterfilter680li.so')
dpkg: regarding .../openoffice.org-core_1%3a2.4.1-11ubuntu2.1_i386.deb containing openoffice.org-core:
openoffice.org-core conflicts with openoffice.org-calc (<< 1:2.4.1-11ubuntu2.1)
openoffice.org-calc (version 1:2.4.1-11ubuntu2) is present and installed.
dpkg: error processing /var/cache/apt/archives/openoffice.org-core_1%3a2.4.1-11ubuntu2.1_i386.deb (--unpack):
conflicting packages - not installing openoffice.org-core
No apport report written because MaxReports is reached already
Preparing to replace libc6-i686 2.8~20080505-0ubuntu7 (using .../libc6-i686_2.8~20080505-0ubuntu8_i386.deb) ...
Unpacking replacement libc6-i686 ...
dpkg: error processing /var/cache/apt/archives/libc6-i686_2.8~20080505-0ubuntu8_i386.deb (--unpack):
corrupted filesystem tarfile - corrupted package archive
No apport report written because MaxReports is reached already
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/linux-image-2.6.27-11-generic_2.6.27-11.27_i386.deb
/var/cache/apt/archives/openoffice.org-calc_1%3a2.4.1-11ubuntu2.1_i386.deb
/var/cache/apt/archives/openoffice.org-writer_1%3a2.4.1-11ubuntu2.1_i386.deb
/var/cache/apt/archives/openoffice.org-core_1%3a2.4.1-11ubuntu2.1_i386.deb
/var/cache/apt/archives/libc6-i686_2.8~20080505-0ubuntu8_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
hot5@hot5-desktop:~$

This is really frustrating! I am fed up with Windows - and Linux has not been cooperating! Is this something I have done? or doing?

Any help would be appreciated!!!