MFC5840CN scanner no device available supported devices are busy

Still [not sure where to post this and] working on getting this scanner to work in Ubuntu but now 10.10. I upgraded my 9.04 via internet to 10.10 a few days ago. I've had the drivers and supporting files installed for a while (9.04) yet Xsane gives me the message that no device available supported devices are busy. I've even removed xsane to see if sane might do the job. Yea sane and xsane are both in there. I recently did a lsusb command and got this response in brackets below:
[????????@????????-desktop:~$ lsusb
Bus 002 Device 002: ID 04f9:016e Brother Industries, Ltd MFC-5840CN Remote Setup Port
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
drmike@drmike-desktop:~$ '/usr/share/applications/gnome-screenshot.desktop']
Should I be concerned about anything in this output like bus 002 having two entries especially when bus 001 and 002 have identical entries in duplicate? I'd try deleting 002 of the identicals but don't feel up to solving a catastrophe if one would result.
Me brain damaged and just finding this data and writing for help was a major hurdle. BTW what the heck is {Linux Foundation 1.1 root hub} and why did it appear twice on separate bus#s?
or instead of deleting Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub should I have a line 'Bus 003 Device 002: ID 04f9:016e Brother Industries, Ltd'? Hope this isn't too much to ask and I did thangs correctly.
I've been looking for instructions on how to get the driver in repositoy also. No luck there yet... brain fatigues out too easy. Thanx agin if you can help!