Ubuntu Linux for beginners and experts. An Ubuntu community with support forums and more.

prob : connexion under console with ubuntu 9.04

Hi ubuntu community, i'm glad to be among you, this is my first post here, and i would like to share some problems.

i'm running ubuntu 9.04 in a virtual machine (VMware workstation6.5 ) under Windows 2000. The company where i'm working are using a "static Ip" , so i had to configure the IP adress, gateway, layer, DNS and the proxy. when i'm loading web pages it works fine, but when i want to register Nessus, under console of course, it gaves me this msg:
----------------------------------------------------
Could not resolve 'plugins.nessus.org'
Could not resolve 'plugins.nessus.org'
Could not open connection to plugins.nessus.org:443
----------------------------------------------------
i figure that it's about https(443). but apt-get does not work as well.
so i'm stuck.
any ideas plz

Create Oscar-Worthy Movie Scripts With Celtx

Celtx is a media pre-production editor that allows you to easily create screenplays and storyboards for your next movie. You can use it to create a whole assortment of media, including theater, comics, advertising, and video games.

Take Awesome Webshots with the Linux Command Line

khtml2png is a helpful tool for capturing an image of a webpage with ease. It's nice to use because it will get the entire length of the site, no matter whether it is fully visible in the browser. And, it sure beats shell scripting Firefox to open on a different display and capturing an image with Imagemagick

Howto install Cherokee web server with MySQL, PHP support on Jaunty

Cherokee is a very fast, flexible and easy to configure Web Server. It supports the widespread technologies nowadays: FastCGI, SCGI, PHP, CGI, SSI, TLS and SSL encrypted connections, Virtual hosts, Authentication, on the fly encoding, Load Balancing, Apache compatible log files, Data Base Balancing, Reverse HTTP Proxy, Traffic Shaper, Video Streaming and much more.

Full Story

Introduction to Web Development with Emacs

Emacs is an absolutely wonderful text editor for designers, and it can speed up development time with a series of helpful shortcuts, even for a Textmate diehard. Unfortunately, Emacs can have a steep learning curve, so I figured I would provide a basic introduction for using Emacs as a web development environment.

Forget About Photoshop: Five CSS Hacks to Help You Stop Using Images

When you are laying out a new design for a web site, the last thing you generally want to do is create a ton of images for the layout. You might make a rounded corner or shadowed text in Photoshop, but that is wasted time if the client doesn’t like it or the website doesn’t turn out as expected. Therefore, here’s a list of some of the different CSS hacks you can use to get around using images.

Installing as dual boot with windows

I'm having trouble installing Ubuntu. I've installed 8.10 before as a dual boot on my machine (Windows XP3) on a 120Gb USB hard disk. My system is set up as : First Hard drive, partitioned to give C: (on which I put Windows XP) D: all my data. 2nd Hard drive: E: a 120Gb usb hard drive, partitioned half and half to give space for backups and for Ubuntu. I had a Windows crash a week ago, had to reinstall Windows on Drive C and although the previous version of Ubuntu still existed on the 120 Gb usb drive, I couldn't get the option to boot into it at startup time. I therefore decided to reinstall Ubuntu (9.04), so I used Aesus partitioner to clean off the old 8.10 version.

how to add class-path for executing java?

HI every 1|
----------can u pls tell how to set class-path---------
I tried in the followind manner,but its not working for me

1)ubntusr@ubntusr:~$ su
Password:

2)root@ubntusr:/home/ubntusr# export $PATH ---------> checking the PATH
bash: export: `/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games': not a valid identifier

3)root@ubntusr:/home/ubntusr# export PATH=/home/ubntusr/Android/java_ee_sdk-5_07-linux.bin ;$PATH
/home/ubntusr/Android/java_ee_sdk-5_07-linux.bin: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory

4)root@ubntusr:/home/ubntusr# export $PATH -------> I m checking wt s there in PATH var after adding java path
bash: export: `/home/ubntusr/Android/java_ee_sdk-5_07-linux.bin': not a valid identifier

5)root@ubntusr:/home/ubntusr# clear ----> not working
Command 'clear' is available in '/usr/bin/clear'

need to open an autocad file with .dwg extension? What program to use?

Need to open an autocad program file with a ".dwg" extension; what ubuntu programs are availalbe? "OpenOffice "draw" didn't seems to work. - Thanks - Patrickgpg

mdadm RAID5 after power outtage

I've searched around all over the internet, and I may have made the mistake of following advice one after another, which could possibly lead to my data loss...

Heres the story:

A few days ago, my RAID5 array of 3x1TB drives went down due to a power outtage. Bootup was stalled due to a failed mounting of my array. CTRL-D to bootup, and take a look at what I'm dealing with.

I "mdadm -E" all of my drives, and they are all clean and identical (not a single drive had been marked unclean or removed) so I tried to assemble using "mdadm -A --scan" which led to an array creation degraded.

The original array (md0) was set up as such:
Slot 0 - /dev/sdb1
Slot 1 - /dev/sdc1
Slot 2 - /dev/sda1

However, upon this assemble, I only had sdc1 and sda1. Odd thing though, instead of assembling in a _UU format, it came out to be U_U.

Back In Time – A Simple backup tool for ubuntu

Back In Time is a simple backup tool for Linux inspired from “flyback project” and “TimeVault”.The backup is done by taking snapshots of a specified set of directories.Keep in mind that Back In Time is just a GUI. The real magic is done by rsync (take snapshots and restore), diff (check if somethind changed) and cp (make hardlinks).

Back In Time acts as a “user mode” backup system. This means that you can backup/restore only folders you have write access to (actually you can backup read-only folders, but you can’t restore them).

Full Story

New user problem

I installed Ubuntu9.04 fresh, then installed eucalyptus. Now, when I boot Ubuntu and open terminal it says rajeev@localhost, that is it doesn't log me in as admin (I've set it to automatic login)
my system name is 'nix'. previously, when i use to open the terminal it said rajeev@nix

Also, now all startup programs don't open, like Network manager doesn't open and I'm not able to logon to the internet. That is I'm not admin, it doesn't allow me to open user and groups tab under Administration.

I haven't used or worked in server environment before, I would like to go back to Ubuntu single desktop again. Do you know a way of fixing this?

My system info is:

Release: 5.0
GNOME: 2.26.1 (Ubuntu (2009-05-06)
Kernel: 2.6.28-13 generic (#45 - Ubuntu SMP Tue Jun 30, 19:49:51 UTC 2009)
OS Type: Linux
GCC Version - 4.3.3 (i486-linux-gnu)
Xorg - Unknown
Hostname - localhost.localdomain

No Operating System Found

--------------------------------------------------------------------------------

I am a newbie at using Ubuntu. I installed it off of a Ubuntu live CD onto my PC currently running Windows XP. The hard drive was partitioned successfully. Now, when I remove the Ubuntu CD, I receive the following error message: 'No Operating System Found'. I would like to restore my Windows environment. Any suggestions? Hopefully, I have not caused any damage to my hard drive. By the way, I don't have a Windows XP recovery CD available. I ran the commands below based on the advise others gave to individuals with a similar problem on other sites. Thank you in advance for your help!

$fdisk -l

Device Host Start End Blocks ID System
/dev/hda1 1 784 6297448+ 12 Compaq diagnostics
/dev/hda2* 785 12161 91385752+ 7 HPFS/NTFS

$cat /etc/fstab

unionfs / unionfs rw 00
tm fs / tmp tmpfs nosuidg nodev 0 0

Ubuntu hangs at boot with video card

I finally got Ubuntu 9.04 installed and all was well.

But I couldn't leave well enough alone.

I installed a video card - NVIDIA Ge Force 5200 (256MB).

Now Ubuntu hangs at the boot screen and I have to manually shut down to reboot. I tried reinstalling - didn't help.

Here's the specs:

Dell Dimension 2300
windows XP sp3
Pentium 4 - 2 Ghz
640 MB RAM
160 GB Hard Drive

Also - ubuntu is installed inside windows xp. I installed the driver that came with the card.The card works fine in windows.

I'd love to hear any suggestions.

Any ideas?

Help My Wireless....Im out of ideas...

So like many of the million posts Ive read I cant get My wireless to work..Ive read and read and read how to make it work...And it has almost..At first my wlan Light wouldnt even come on but now it comes on and still doesnt connect..I am new to Linux..I went to partition and well i MESSED UP and wiped out XP without backing it up...Wich is ok with me because i really wanted to learn and what better way than not looking back..So in a bunch of forums they say do this and that and I think ive done it all but still coming up short so im going to swallow my pride and the maybe hundred hours ive spent over the last week reading and trying whatever i can and now ask for help.. this is were i stand justin@justin-laptop:~$ sudo lspci
[sudo] password for justin:
00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:05.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge