Problem: screen freezes during installation

Hi, I've recently purchased a laptop with spec as follow: Processor : Intel Pentium Dual-Core Processor T2390 (1.86 GHz, 1M cache, 533 MHZ FSB) Memory : 1 GB Graphics : SiS Mirage3+Graphics (Sis M672) up to 256 MB Display : 12.1" WXGA (1280X800) TFT LCD Storage : 1xHDD SATA Seagate 120 GB Brand : Axioo No Operating System Installed The ubuntu version I tried to install is the latest 8.10 for desktop version.During the installation, after selecting the option install Ubuntu, it continues to the screen with the progress bar. After that, it freezes in the reddish-brow colour screen. I have tried other alternatives such as Try Ubuntu without any change to your computer, Install Ubuntu in safe Graphics mode. But it won't work.Can anybody help me out to install this OS? I really appreciate your help. Thanks.

Yes, but what is the laptop?

Yes, but what is the laptop? Make and Model?

Laptop Brand

Hi Alan. My Laptop brand is Axioo. Type Neon TVR812P.

unable to install ubuntu

For three weeks now I'm trying to install ubuntu 8.10 on a modified PC.  Thihs desktop was running withWIN XP and KUBUNTU 7.10 Three changes have been made a heavier power supply, a new graphics card and an additional hdd were added. The same symptom as described occured again and again. I' tried the installation after removing the graphics card, the hdd, changed the configuration n times.In safe mode the installer ends with a long list of messages with a last sentence:115.957356 agpgart:agp aperture is 128 M @ 0XD00000000When running in windows no problems occur.Tomorrow I'm going to buy a new PC

Have a look at

Have a look at https://help.ubuntu.com/community/BootOptionsThe problem might be your SIS video. The relevant option might be: xforcevesa As it says this will : Force X to start using VESA driver. Useful for some notebooks with uncommon video interfaces.

Thanks Alan!! It works.

Thanks Alan!! It works.

Good. Now make sure that you

Good. Now make sure that you have the package installed called xserver-xorg-video-sis and try a normal boot. Synaptic says: X.Org X server -- SiS display driver This package provides the driver for all SiS and XGI Volari cards.