Steps for Installation of VLC 0.8.6 & above on UBUNTU

Download and Installation Steps for VLC (0.8.6 and above) on UBUNTU 8.04

Lets start...

There are two versions of VLC (the Release version and the Test version which is often knows as Nightly Builds)

STEP - 0a
Get Release VLC source code via Git

$ git clone git://git.videolan.org/vlc.git

or if u want nightly build than
STEP - 0b
Get Nightly VLC source code via Git
To get nightly code you need to edit your "/etc/apt/sources.list" file
and add any of the following lines

    For Ubuntu Intrepid I386 (unstable) add the following line to your sources.list:
    deb http://nightlies.videolan.org/build/intrepid-i386/arch ./

    For Ubuntu Intrepid AMD64 (unstable) add the following line to your sources.list:
    deb http://nightlies.videolan.org/build/intrepid-amd64/arch ./

    /************ I added this one for my requirement ***********/
    For Ubuntu Hardy I386 (stable) snapshot add the following line to your sources.list:
    deb http://nightlies.videolan.org/build/hardy-i386 /
    /***************************************************************/

    For Ubuntu Breezy I386 snapshot add the following line to your sources.list:
    deb http://nightlies.videolan.org/build/breezy-i386 /

    For Ubuntu Dapper I386 snapshot add the following line to your sources.list:
    deb http://nightlies.videolan.org/build/dapper-i386 /

than do


    sudo apt-get update
    sudo apt-get upgrade

NOTE: if you dont want nightly build than DONOT add any of the above lines, because if you do and then do update or upgrade it will overwrite the old code

STEP - 1

Before bootstraping or configuring VLC first do this


    sudo apt-get build-dep vlc
    sudo apt-get install autoconf (if not already installed)
    sudo apt-get install automake (if not already installed)


STEP - 2

Now goto the respective vlc directory and type in the console following

    ./bootstrap


STEP - 3a

than do configure (with appropriate parameter/OPTIONS), OPTIONS could be like --enable-release or --enable-mozilla (to enable vlc plugin for mozilla firefox) etc.

    ./configure --prefix=/usr [OPTIONS]


STEP - 3b

In configure, if it gives error on certain missing libraries than install them, whereas typical missing libraries you may install will be

    sudo apt-get install libqt4-dev
    sudo apt-get install libXpm-dev

...it actually depends on your configure OPTIONS. Anyway move forward to

STEP - 4

After successful configure step, continue towards 'make'

    make


STEP - 5

than login as root password by typing

    su

than its password and then type

STEP - 6

    make install

Few notes:
If u have configured with --enable-mozilla than libvlcplugin.so would have been made in /usr/lib/mozilla/plugins/ , but you will need to copy it in your firefox and xulrunner plugins directory to correctly configure it, someitmes configuration breaks...

/coldfire

MPEG4/H.264 Papers & Ebooks